MaJaProL:Hardware

Aus II-Wiki
Wechseln zu: Navigation, Suche

Entwicklung der Hardware

MISSION COMPLETE

Die Hardware läuft und alles leuchtet. Mit 5 Tagen Verspätung verkünde ich:

  • 21 Module sind betriebsbereit
  • 328 LEDs leuchten
    • die Hälfte sind Weiß mit 10.000 mcd und die andere Blau mit 7000 mcd (milli candela)
    • 164 Paare sind einzeln ansteuerbar

Status 18.05.2006

  • den Kabeldreher auf dem Mainboard hab ich gestern beseitigt.
  • bis in den Morgen hinein haben Peter und ich die LEDs über dem Bett entfehlert (engl: "debugged" ). Das größte Problem waren Steckerverbindungen, die entweder Datenleitungen kurzgeschlossen oder nicht richtig mit den Kabeln verbunden waren.
  • es reagieren noch 3 Module über dem Kühlschrank nicht. Wahrscheinlich gibt es dort auch wieder Probleme mit den Steckern.


Status 15.05.2006

  • ich habe die Deadline um einen Tag überschritten

Auf Anraten meines Psychologen werde ich mir keine weitere Deadline setzten. Dies soll mich vor weiteren psychischen Belastungen schützen ;-)

  • zudem ich habe einen wichtigen systematischen Fehler gefunden und korrigiert. (vorerst mittels einem Taschenmesser und etwas Klebestreifen). Nun arbeitet ein Großteil der Schieberegister ordnungsgemäß. Zudem wirkt sich das Betätigen des Lichtschalters bzw. das Einschalten des Kühlschranks nicht mehr auf die LEDs aus.
  • einen fießen Kabeldreher auf dem Mainboard, werde ich morgen mittels Lötkolben bekämpfen

Status 11.05.06

  • habe endlich den 11 cent teuren Stecker bekommen (nach 6 Tagen)
  • neue Probleme sind aufgetaucht:
    • alle LEDs leuchten (bis auf ein Paar)
      • leider vollkommen undefiniert
    • ich habe Spannungen, wo keine sein sollten
    • wenn der Kühlschrank angeht, gehen die LEDs aus
    • wenn ich den Lichtschalter betätige gehen auch n paar LEDs aus

Ich hab ja garnicht damit gerechnet, dass gleich alles funktioniert. Ich werde den Termin wohl doch noch nach hinten raus verschieben müssen


Status 10.05.06

  • alles ist soweit fertig:
    • Mainboard
    • Spannungswandlerboard mit Kühlkörper
    • Testprogramm
    • ...
  • nur fehlt der Stecker um das Parallelportkabel mit dem Mainboard zu verbinden

seit 5 Tagen warte ich darauf und Reichelt bekommts nicht gebacken das Teil nach Ilmenau zu liefern *ausrast*


Status 4.5.06

  • Dank Peter sind nun endlich alle LEDs an der Decke. endlich !
  • Das Mainboard hab ich heute auch noch fertig gelötet
  • Zimmer ist wieder einigermaßen bewohnbar. juhuuuuu


Status: 1.05.06

  • habe die Feiertage genutzt um die letzte besch***ene Arbeit zu erledigen (die LED-Module mit den einzelnen LEDs zu verdrahten).
  • alle Module wurden verdrahtet und auf Funktionsfähigkeit überprüft. -> läuft blendend ^^
  • meine liebreizende Assistentin hat sich dem Mainboard hingegeben. Dieses ist nun zu 95% fertig. Dankeschön nochmal ;-)
  • habe die Bestellung des PFL26 Steckers in Auftrag gegeben. Das ist der, den ich brauche um das Mainboard mit dem Parallelport zu verbinden.

Anmerkung: Ich habe mir gegenüber im C-Block ein Zimmer gefunden, durch dessen Vorhang blaues Licht scheint *ausrast*: Der wird den Vorhang wohl auch brauchen, wenn ich erstmal meine Beleuchtung aufdrehe und aus Versehen sein Zimmer beleuchte ....muwhaahaaaha


Status: 28.04.06

  • Spannungsversorgung ist Dank Svens Kühlkörper und Peters Netzteil vorerst sichergestellt, muss aber noch ins "final release" überführt werden
  • erstes Schieberegistermodul an Kabelkananalabdeckung montiert; mit LEDs, Logik- und Spannungsversorgung verbunden
  • Leuchttest der ersten 14 LED (von 328) war erfolgreich